Back to overview
Degraded

Degraded performance from third party authentication provider

Feb 19, 2026 at 05:14pm UTC
Affected services
Web

Resolved
Feb 19, 2026 at 06:38pm UTC

The incident has been resolved! Dashboard access has been restored back to normal.

Updated
Feb 19, 2026 at 05:38pm UTC

Clerk has deployed and are continuing to see improvements. We'll be continuing to monitor to see when a full recovery has deployed.

Created
Feb 19, 2026 at 05:14pm UTC

Clerk, our third party authentication provider, is having degraded performance (https://status.clerk.com/incidents/01KHVBF47Q3SDK1VX7ZNHQ316R). We are actively monitoring the situation. Logging into the Cyberdesk dashboard may be degraded for this time.